#0  APMSETUP PHP 버전 업그레이드 PHP5.4.14 


apmsetup.com 에서 제공하는 php 버전은 5.2 이다. 


PHP 5.2에서 지원되지 않는 혹은 고쳐진 버그가 종종 있어서

답답해서 버전업을 해 보았다. 



#1. php 버전을 받는다 


#1-0 php.net 에서 windows binary를 받자 





#1-1 

APMSETUP 으로 설치한 경우라면 Thread Safe 버전을 받으면 된다. 







#1-2 불안하다면 phpinfo() 에서 기존버전이 thread safe 버전임을 확인 





#2. 받은파일을 압축을 풀자.  

PHP 5.4.14 기 때문에 PHP54 로 디렉토리명을 변경하였다. 





#3. php.ini 파일 저장 


APM_SETUP 최상위 폴더에 php.ini 파일을 교체해주자. 

기존 php.ini를 혹시 모르니 다른 이름으로(_php.ini) 보존하고, 



압축 푼 PHP54 내부에 있는 php.ini 를 복사해서 가져오자. 

나는 php.ini 샘플 중 

php.ini.development 를 복사해서 사용하였다. 








#4. Apache에서 php 설정 변경 


APMSETUP\Server\Apache\conf\extra 에 보면 

httpd-php5.conf 파일이 있다. 


해당 파일에서 

PHP5/php5apache2_2.dll 을 load하게 되어있는 부분을 새 버전 경로로 변경해주자 

PHP54/php5apache2_2.dll 로 변경하면 된다. 






#5. 그러고 나서 APMSETUP Mornitor에서 재시작을 하면 된다. 

PHP 5.4.14 라고 나온다. 





#6. php.ini 설정 


제대로 되는 줄 알았는데 timezone 관련 에러가 난다.

해당 설정이 주석처리가 되어있다. 

; date.timezone = 

단계 #3에서 복사한 php.ini 를 열어서 관련 설정을 추가하자 

date.timezone = Asia/seoul 




extension path도 설정해주자 

extension_dir = "D:/APM_Setup/Server/PHP54/ext"






#7. 덧 

MySQL 모듈 등이 정상 동작하지 않으면 

php.ini에서  extension 부분을 보자. 



사용하는 모듈은 주석을 제거하고 Apache를 재시작해주자. 







'01_Note' 카테고리의 다른 글

Windows 에서 PHP 실행하기  (0) 2017.10.02
Redis  (0) 2013.12.31
APMSETUP PHP version upgrade  (1) 2013.05.05
eula.1028.txt 의 정체  (9) 2011.09.26
  1. 두두리이 2014.08.22 01:36 신고

    php 5.5 로 올렸더니 apache2.4가 필요하더라
    http://www.apachelounge.com/download/
    여기서 apache 도 올려주자

+ Recent posts